Does TFS Plug-in for CCNet work on VSTS 2008 beta?

Topics: User Forum
Aug 24, 2007 at 7:00 AM
I have shifted from VSTS 2005 to VSTS 2008 beta (along with the TFS). In order to use TFS 2008 beta Source Control system from CCNet, is any
plugin available? Right now, CCNet gives following error with TFS Plugin for CruiseControl.NET 1.1
===============================
CCProj:ERROR INTERNAL ERROR: Could not load file or assembly ' Microsoft.TeamFoundation.VersionControl.Client, Version=8.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
===============================

I think, the plugin is NOT compatible with VSTS 2008 beta Source Control System (TFS).


Correct me if I am missing something. If any new version of plugin, compatible with VSTS 2008 Source Control System, is available please let me know.
Aug 24, 2007 at 11:25 AM
Edited Aug 24, 2007 at 11:26 AM
If the VS2005 Team Explorer binaries are available of the CruiseControl machine then the plug-in can use these to talk to a TFS 2008 source control system and it works just great. (The TFS 2005 and TFS 2008 clients can both be installed on the same machine and they work side by side)

The other alternative is to recompile the plug-in from the source control distribution against the TFS 2008 (Beta 2) Assemblies.

Hope that helps.

Martin.