WorkingDirectory vs Workspace

Topics: User Forum
Jan 8, 2007 at 12:38 PM

I'm fairly new to TFS and CC.Net. I've set up CC on my server, and in my ccnet.config file, I've set my workspace and my workingdirectory to:

<workingDirectory>C:\Program Files\CruiseControl.NET\server\EVA.Net\WorkingDirectory</workingDirectory>

running the ccnet console application gives the following error message in the log-file:

System.ArgumentNullException: Value cannot be null.
Parameter name: localItem at Microsoft.TeamFoundation.VersionControl.Common.VersionControlUtil.CheckStringForNullOrEmpty(String stringVar, String stringVarName)
at Microsoft.TeamFoundation.VersionControl.Client.WorkingFolder..ctor(String serverItem, String localItem, WorkingFolderType type)
at Microsoft.TeamFoundation.VersionControl.Client.Workspace.Map(String serverPath, String localPath)
at ThoughtWorks.CruiseControl.Core.Sourcecontrol.Vsts.GetSource(IIntegrationResult result) in C:\projects\opensource\vstsplugins\trunk\source\ccnet\ccnet.vsts.plugin\Vsts.cs:line 184
at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Build(IIntegrationResult result)

Any help will be greatly appreciated

Jan 8, 2007 at 2:56 PM
Hi, have you set up the project path?

It looks like it is not picking up your working directory path for some reason. I have recently checked in a fix that would stop the error in that case, but that doesn't explain why it isn't picking up your working directory.

If possible, can you post the full vsts block from the ccnet.config? If you don't really want to post it publicly you can email it to me at


Jan 9, 2007 at 8:36 AM
> Martin wrote:
> Looks like you are running into a bug that was recently reported to
> be. I have checked in a fix to CodePlex but haven't done a new
> release yet with it in because I was wanting to add some other
> features / fixes.

> If you want you can compile your own version of the plug-in from
> the source code on CodePlex. Alternatively, you can work around
> the issue by providing a "workingDirectory" inside your source
> control block.

Hi Martin

Adding a "workingDirectory" inside the source control block gave me the follwing exception:

Microsoft.TeamFoundation.VersionControl.Client.MappingConflictException: The path C:\Documents and Settings\AutoBuilder\My Documents\Visual Studio 2005\Projects\MyProject is already mapped in workspace.

I downloaded the source code from Codeplex and compiled it. removing the extra "workingDirectory" and running again gave me the same exception!?! Hmmm - I then changed working directory to " C:\Program Files\CruiseControl.NET\server\MyProject\WorkingDirectory" and - it worked!!! (well, I do get an exception that it cannot find nant, but that's another story).

I'm not quite sure, why the working directory cannot be the project-path in My Documents - but there is probably an answer to this.

Thanks for your help, Martin