You Are Not Authorized Exception

Topics: Developer Forum, User Forum
Mar 18, 2007 at 7:15 AM
first of all thank you for your greate add-on
I establishing new project on CodePlex.com
I configured ccnet.config as following

<sourcecontrol type="vsts" autoGetSource="true" applyLabel="false">
<server>https://tfs01.codeplex.com:443</server>
<username>snd\MYUSERNAME_cp</username>
<password>MYPASSWORD</password>
<domain>SND.RNO.GBL</domain>
<project>$\MYPROJECT</project>
<workspace>MYWORKSPACE</workspace>
<deleteWorkspace>false</deleteWorkspace>
<workingDirectory>E:\Test</workingDirectory>
</sourcecontrol>

and when I try to run ccnet.exe it prompts me with "You Are Not Authorized ...." , I tried to play with values but no good result, so I come to ask if any one has a successful configuration to codeplex and to know what wrong with my configuration

Mar 18, 2007 at 7:02 PM
Things to check:

0. Did you mean to type $\MYPROJECT? I believe it has to be $/MYPROJECT.
1. CodePlex has two active TFS servers, tfs01 and tfs03. Make sure your server choice is correct.
2. Make sure that the username & password you're using belong to an account that is a developer or coordinator on the project.
Mar 18, 2007 at 10:30 PM
Edited Mar 18, 2007 at 10:33 PM
Hi Brand Thanks so much for your reply

I'm AhmedMozlay posting form test account I created new test project on codeplex in order to provide you with real project data
here is the info of the test project I created

Project Title: Some.Project
URL: www.codeplex.com/someproject
Team Foundation Server name:tfs03.codeplex.com
Port number:443
Protocol:https
Username:snd\SomeOne_cp
Password:SomePassword


note the "dot" in project title
would you please provide me with the right configuration xml elements because I'm stuck
Mar 18, 2007 at 11:42 PM
Looks to me like you want something like this:

<sourcecontrol type="vsts" autoGetSource="true" applyLabel="false">
  <server>https://tfs03.codeplex.com:443</server>
  <username>USERNAME_cp</username>
  <password>PASSWORD</password>
  <domain>SND</domain>
  <project>$/Some.Project</project>
  <workingDirectory>E:\Test</workingDirectory>
</sourcecontrol>
Good luck!
Mar 19, 2007 at 7:39 AM
I tried this

    <sourcecontrol type="vsts" autoGetSource="true" applyLabel="false">
      <server>https://tfs03.codeplex.com:443</server>
      <username>snd\SomeOne_cp</username>
      <password>SomePassword</password>
      <domain>SND</domain>
      <project>$/Some.Project</project>
      <workingDirectory>E:\Test</workingDirectory>
    </sourcecontrol>

I tried user name & password by login into codeplex and they are working fine
however my ccnet can't connect and still prompts me with "you are not authorized..."
Mar 19, 2007 at 7:48 AM
It works it works
it was the damned "snd\" I was thinking it is a part of the username but finally I found the brilliant question "Why I need this stuff ?"
I removed "snd\" and it works
Some times I need F5 , it was in front of my eyes all the time

Thanks Brad so so much for your valuable help

Mar 19, 2007 at 3:05 PM
Maybe Martin can add some logic which detects when you've specified the domain both in the <domain> settings and the <username> setting and throw an error back? :)

Glad to hear it's all working!
Mar 20, 2007 at 2:23 PM
This discussion has been copied to Work Item 9030. You may wish to continue further discussion there.