Unable to get CC.Net build using TFS Team Build

Topics: Developer Forum, User Forum
Oct 16, 2007 at 1:15 AM
I get the following error message in CCNet.log (and nothing else) when I try to use the ccnet.config below. What am I missing? Any help is appreciated.

Thanks
Omid

CCNet.log
2007-10-15 17:08:16,356 CCNet Server:DEBUG The trace level is currently set to debug. This will cause CCNet to log at the most verbose level, which is useful for setting up or debugging the server. Once your server is running smoothly, we recommend changing this setting in D:\Program Files\CruiseControl.NET\server\ccservice.exe.config to a lower level.
2007-10-15 17:08:16,372 CCNet Server:INFO Reading configuration file "D:\Program Files\CruiseControl.NET\server\ccnet.config"

CCNet.Config

<cruisecontrol>
<project name="TFS Phase I Solution Build">
<sourcecontrol type="vsts" autoGetSource="true" applyLabel="false">
<project>$/IDC/Source/</project>
<workingDirectory>d:\Workspaces\BuildWorkspace\Source\</workingDirectory>
<cleanCopy>false</cleanCopy>
<server>http://TFSServer:8080</server>
<username>tfsUser</username>
<password>abcd</password>
<domain>TFSDomain</domain>
<workspace>BuildWorkspace</workspace>
<deleteWorkspace>false</deleteWorkspace>
</sourcecontrol>
<labeller type="defaultlabeller">
<prefix>Automated-Build-</prefix>
<incrementOnFailure>true</incrementOnFailure>
</labeller>
<tasks>
<teambuild>
<tfsServerUri>http://TFSServer:8080</tfsServerUri>
<teamBuildServer>TFSServer</teamBuildServer>
<teamProject>IDC</teamProject>
<teamBuildType>ComponentsBuild</teamBuildType>
<workspace>TFSServerIDCComponentsBuild</workspace>
<dropsLocation>\\TFSServer\TFSpublishArea</dropsLocation>
<msBuildParameters>
<MsBuildParameter>/v:d</MsBuildParameter>
<MsBuildParameter>/logger:ThoughtWorks.CruiseControl.MsBuild.XmlLogger,ThoughtWorks.CruiseControl.MsBuild.dll;msbuild-output.xml</MsBuildParameter>
<MsBuildParameter>/p:SkipInitializeWorkspace=true</MsBuildParameter>
<MsBuildParameter>/p:SkipGet=true</MsBuildParameter>
<MsBuildParameter>/p:SkipClean=true</MsBuildParameter>
<MsBuildParameter>/p:SkipDropBuild=true</MsBuildParameter>
</msBuildParameters>
<useMsTest>false</useMsTest>
<useMsTestCodeCoverage>false</useMsTestCodeCoverage>
</teambuild>
</tasks>
<publishers>
<merge>
<files>
<file>D:\Workspaces\BuildWorkspace\IDC\ComponentsBuild\Debug\msbuild-output.xml</file>
</files>
</merge>
<xmllogger>
<logDir>.\Web\Logs</logDir>
</xmllogger>
</publishers>
</project>
</cruisecontrol>