No modifications detected

Topics: User Forum
Nov 24, 2006 at 5:54 PM
I have installed CruiseControl.NET with prerequisites on a machine together with the TFS Plugin, but I can't get it to work; it simply will not retrieve any files from TFS. Maybe I just did something fundamentally wrong... Anyway, ccnet.log has lots of lines like these:
--------------------------------
2006-11-24 19:52:59,480 <project name>:DEBUG Checking Team Foundation Server for Modifications
2006-11-24 19:52:59,480 <project name>:DEBUG From: 2006-11-24 16:57:20 - To: 2006-11-24 19:52:59
2006-11-24 19:52:59,960 <project name>:DEBUG Found 0 modifications
--------------------------------

It seems as if TFS thinks that the buildserver is already up-to-date with all files, but not one single file has ever been fetched to the buildserver from TFS. Any spontaneous idea what I might have missed?
Nov 26, 2006 at 5:27 PM
Never mind, it seems as if I had screwed up the config file in some way; got it working now :o)
Oct 30, 2008 at 12:00 AM
Hi,
I am having same problem please help

<triggers>
<intervalTrigger seconds="60" buildCondition="IfModificationExists" />
</triggers>

sourcecontrol type="vsts" autoGetSource="true" applyLabel="false">
  <server>testTFS</server>
  <project>$/TestHarness</project>
  <workingDirectory>C:\Workspaces\QA\TestHarness</workingDirectory>
</sourcecontrol>
   
    <!-- Build using MSBuild (2008) -->
    <tasks>
      <msbuild>
      <executable>C:\WINDOWS\Microsoft.NET\Framework\v3.5\MSBuild.exe</executable>
      <workingDirectory>C:\Workspaces\QA\TestHarness</workingDirectory>
      <projectFile>TestHarness.sln</projectFile>
      <buildArgs>/noconsolelogger /p:Configuration=Debug /v:diag</buildArgs>
      <targets>Build</targets>
      <timeout>15</timeout>
      <logger>C:\Program Files\CruiseControl.NET\server\ThoughtWorks.CruiseControl.MSBuild.dll</logger>
    </msbuild>