Exception in sorcecontrol block

Topics: User Forum
Mar 28, 2007 at 3:41 AM
Now I'm configuring CruiseControl.NET to work with Visual Studio Team
Foundation. I've got TFS Plugin for CruiseControl.NET 1.1 and CC.NET
1.1.0.2498 installed on my computer (i'm not sure the version of the VSTF server, how can i get that version information?). the sourcecontrol block of my
CC.net configuration is:

<sourcecontrol type="vsts" autoGetSource="true"
applyLabel="false">
<server>http://vstfserver:8080</server>
<username>billy</username>
<password>mypassword</password>
<domain>fareast</domain>
<project>$/Test/ConsoleApplication1</project>
<workingDirectory>c:\projects\Test
\workingdirectory\src</workingDirectory>
<cleanCopy>false</cleanCopy>
<deleteWorkspace>false</deleteWorkspace>
</sourcecontrol>

now I can connect to VSTF server and if I modify some files in VSTF,
CC.NET can detect changes, but the subsequent execution will report an
error (see the last line of the LOG1 below) and my working directory is
still empty (a latest copy of source code should be there i think) .
The problem should be in this block, because I deleted almost all
other blocks in configuration, but the problem remained the same.

if i change
<cleanCopy>false</cleanCopy> and <deleteWorkspace>false</deleteWorkspace>
to all 'true', there are some new log information as LOG2.


LOG1:

2007-03-27 10:39:39,362 1236:DEBUG The trace level is currently set
to debug. This will cause CCNet to log at the most verbose level,
which is useful for setting up or debugging the server. Once your
server is running smoothly, we recommend changing this setting in C:
\Program Files\CruiseControl.NET\server\ccnet.exe.config to a lower
level.
2007-03-27 10:39:39,378 1236:INFO Reading configuration file "C:\Program Files\CruiseControl.NET\server\ccnet.config"
2007-03-27 10:39:39,456 1236:INFO Registered channel: tcp
2007-03-27 10:39:39,456 1236:INFO CruiseManager: Listening on url:tcp://172.25.190.107:21234/CruiseManager.rem
2007-03-27 10:39:39,456 1236:INFO Starting CruiseControl.NET Server
2007-03-27 10:39:39,456 Test:INFO Starting integrator for project:Test
2007-03-27 10:39:39,690 Test:DEBUG Checking Team Foundation Server for Modifications
2007-03-27 10:39:39,690 Test:DEBUG From: 3/27/2007 10:38:47 AM - To: 3/27/2007 10:39:39 AM
2007-03-27 10:39:41,909 Test:DEBUG Found 1 modifications
2007-03-27 10:39:41,909 Test:INFO 1 modification detected.
2007-03-27 10:39:41,909 Test:INFO Building: IntervalTrigger triggered a build (IfModificationExists)
2007-03-27 10:39:42,518 Test:DEBUG Existing workspace detected - reusing
2007-03-27 10:39:42,534 Test:INFO Integration complete: Exception - 3/27/2007 10:39:42 AM

LOG2:
2007-03-28 10:10:57,509 Test:DEBUG Found 1 modifications
2007-03-28 10:10:57,509 Test:INFO 1 modification detected.
2007-03-28 10:10:57,509 Test:INFO Building: IntervalTrigger triggered a build (IfModificationExists)
2007-03-28 10:10:57,509 Test:DEBUG Deleting c:\projects\Test\workingdirectory\src
2007-03-28 10:10:58,102 Test:DEBUG Creating new workspace name: CCNET
2007-03-28 10:10:58,149 Test:DEBUG Deleting the workspace
2007-03-28 10:10:58,180 Test:INFO Integration complete: Exception - 2007-3-28 10:10:58

Why CC.NET report this error?

Thanks!!

Billy
Jun 21, 2007 at 5:46 PM
I am getting this same problem.
Jul 8, 2007 at 2:18 PM
Hi guys, I think you made the same mistake as me. Have you created a workspace manually that is located in c:\projects\Test
\workingdirectory\src? For me that was the problem. Make sure that the value to you give to <workingDirectory> is not a directory that is currently know by your TFS server.

I hope that helps,
Maxime
Jul 20, 2007 at 3:06 PM
That wasn't the problem I had, but I am going to start a new thread.
Apr 4, 2008 at 8:06 PM
I'm getting the same error... Does anybody have an idea on what's going on???